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Word macros
really!

By Bob Mohr

STC Senior Member

he word macro seems to
T frighten a lot of people. They
immediately think, “Uh oh,

that’s programming stuff. No thanks!”

Microsoft Word macros are
programs, of a sort, but you don’t
have to know about programming to
take advantage of them. I'll show you
how to exploit Word’s power—with
macros—and without programming.

So, what is a macro—really?
Word’s online help defines macros
this way: A macro is a series of Word
commands and instructions that you
group together as a single command to
accomplish a task automatically. Instead
of manually performing a series of time-
consuming, repetitive actions in Word,
you can create and run a single macro—
in effect, a custom command—that
accomplishes the task for you.

made easy—

The help also goes on to say:

Here are some typical uses for macros:

* To speed up routine editing and
formatting

* To combine multiple commands

* To make an option in a dialog box
more accessible

* To automate complex series of tasks

Let me offer a simple example.
How many times have you wanted to
print the current page of a multi-page
document? Likewise, how many times
have you gone through the repetitive
routine of clicking File>Print,
selecting Current Page, and clicking
OK? Sure, two of the clicks are
eliminated by using Ctrl+PB, but
they're replaced by two keystrokes.
You can print the current page of a
document with just one mouse click:
Use a macro!

continued on page 3
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Rough Draft is the official
publication of the Society for
Technical Communication, Phoenix
chapter.

Published monthly, Rough Draft
prints news about chapter events and
members and publishes members’
opinions on technical communication
topics.

We invite readers to submit
material on subjects of interest to
Society and chapter members. Please
credit reprinted material and send a
copy of the original to the editor.

Newsletter staff

Kathy Graden, Newsletter
Editor and Manager
Carl Gotlieb, Copyeditor

Submitting material

We accept material submitted as e-
mail or ASCII files in FrameMaker
format or MS-Word format. (Please
include a printed copy and your phone
number.) We prefer GIF or TIF
graphics. If faxing material, first call
623-581-4589 or 602-788-6049.
Material received by the first of the
month usually is published in the next
issue.

We reserve the right to edit articles
for clarity and length. We try to review
substantive editing of feature articles
with the author before publication.
Obur style guide is Words into Type.

Advertising rates

1/6 page $25 1/3 page $50
Call for 1/2 or full page rates. Ads

for job openings are free.

Issue Deadline
July June 1
August July 1
September  August 1
October September 1

Rough Draft © STC, Phoenix
chapter, 2001

ABOUT STC

The Society for Technical Communication (STC) is an international, nonprofit organization
dedicated to furthering the art of communicating technical information and promoting the
education, improvement, and advancement of its members. Membership is open to those
employed in, interested in, or concerned with the profession of technical writing, information

design, publishing, or associated disciplines.

Mission statement

The Phoenix chapter of STC is recognized as the hub of technical communication where members
enhance their skills and knowledge while building professional relationships.
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General chapter business
Hotline: 602-553-4321

E-mail: johnbri@primenet.com
Website: www.stc-phoenix.com

Address changes and membership
applications
U.S. Mail:  STC, 901 Stuart St., Ste. 904
Arlington, VA 22203-2854
Newsletter (not for address corrections)
Editor/manager: Kathy Graden

Employment and job referrals

Manager:  Dottie Tucker
Voice: 480-595-9326
E-mail: ditucker@mindspring.com

STC international office

U.S. Mail:  STC, 901 Stuart St., Ste. 904
Arlington, VA 22203-1854

Voice: 703-522-4114

Web site: www.stc.org

U.S. Mail:  AG Communication Systems, Director-sponsor
2500 W. Utopia Road, Region 5:  Suzanna Laurent
Phoenix, AZ 85027 Voice: 405-376-4210

Voice: 623-581-4589 Fax: 405-951-9444

Fax: 623-582-7009 E-mail: slaurent@prodigy.net

E-mail: gradenk@agcs.com

Phoenix chapter board of directors
Position Name Preferred E-mail, Other
President Freya Winsberg 480-657-4257 (w)  freyawins@hotmail.com
602-861-1933 (h)
External VP Tim Eull 480-592-1406 (w)  timothy.eull@honeywell.com
Internal VP Amy Shogan 602-494-8186 (h)  amshogan@yahoo.com
Secretary Kathy Graden 623-581-4589 (w)  gradenk@agcs.com
Treasurer Lisa Brashear-Ford 480-820-5724 (h) lisaford-tq@home.com
Immed. Past Pres. Tom Barnett 602-236-6914 (W)  tpbarnet@srpnet.com
CARSEF Gloria McConnell  602-313-4058 gloria.mcconnell@honeywell.com
Education Wendy Bellows ~ 602-444-4735 wendy.bellows@pni.com
Employment Dottie Tucker 480-595-9326 ditucker@mindspring.com
Hospitality Dana Osborne 602-942-4112 dana_osborne@hotmail.com
Insider’s Guide open
Membership Sherry Michaels ~ 480-614-8440 smichaels@docntrain.com
Mem. Directory John Brinegar 602-278-7398 johnbri@qwest.net
Membership Survey open
Newsletter Kathy Graden 623-581-4589 (w)  gradenk@agcs.com
Nominations Tom Barnett 602-236-6914 (w)  tpbarnet@srpnet.com
PAO Competitions  Carl Gotlieb 602-789-9428 (h)  gotliebc@agcs.com
(

Programs

Public Relations
Society Exhibits
Student Advisor
Tech Comm Week
Voice Mail, E-mail

Volunteer Manager

Web Site

Maura Betler
Linda Shacklock
Aiessa Moyna
Janice Kruse
Marian Barchilon
Tom Barnett
John Brinegar
Valerie Toliver
Dottie Tucker
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480-948-3544 (w)
480-814-1004
480-314-4367
480-941-8112
480-727-1669 (w)
602-236-6914 (w)
602-278-7398
602-277-2356
480-595-9326

maura_betler@g1.com
Ishacklock@qwest.net
aiessa.m.moyna@aexp.com
jan.kruse@ips-sendero.com
barchilon@asu.edu
tpbarnet@srpnet.com
johnbri@qwest.net
vtoliver@earthlink.net
ditucker@mindspring.com
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Word macros made easy—really!
continued from page 1

To create the macro, you record
the exact keystrokes (or mouse
clicks) you would normally use to
accomplish printing the current
page. Begin with the macro recorder:

1. Click Tools>Macro>Record
New Macro. The Record Macro
dialog box appears.

2. Type a name for the new macro.
Make the name something mean-
ingful like PrintPage.

3. Click OK. A Stop Recording
toolbar appears on the screen, and
a cassette icon is attached to the
mouse pointer. From this point on,
whatever you type and whatever
you click are included in the
macro.

Now you can record the steps to
print the current page:

1. Click File>Print>Current

Page.

2. Click OK.
3. Click the Stop Recording

button on the macro toolbar.

You now have a macro, stored in
the Normal.dot file, called PrintPage.
To make the macro easy to access,
assign it to a toolbar or menu. Once
the PrintPage macro is assigned to a
toolbar, clicking it always prints the
currently displayed document page.

The PrintPage example is great for
creating macros of a permanent
nature, but you can also create
macros for repetitive tasks that you
may never do again. For example, |
once had the misfortune to work on
a document that was full of
“formatted” paragraphs that were
shaded, bolded, center-justified, and
in the wrong font. Had the author
created his abomination using styles,
I could have changed the formatting
of the styles easily, but the whole
document (50+ pages) used the
normal style.
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Here’s how the troublesome
paragraphs looked in the original
document:

HRESULT GENERATEXML.([ouUT,
RETVAL] BSTR STRXML);

Can you imagine “manually”
formatting dozens of paragraphs like
this? I can’t.

[ first created a new style that I
later applied to the text line. Then, I
recorded a macro to remove the
previous formatting and apply the
style. Following are the highlights of
what I did.

I started the macro recorder and,
at the Record Macro dialog box:

1. Clicked the keyboard icon. The

customize Keyboard dialog box was

displayed.

2. Pressed Alt+X. I frequently use
these two keys, since they are close
together and are quickly operated
with two fingers.

3. Clicked Assign.
4. Clicked Close.

The Macro Record toolbar was
displayed and ready to record. I then
deleted the lines above and below
the text, then applied the new style
to the text line.

When finished, the modified text
line looked like this, without the
backgroundshading:

HRESULT Gener at eXM_([ out,
retval] BSTR strXWM);

After saving the macro, all I had to
do was place the insertion point at
the beginning of each paragraph
block and press Alt+X to instantly
transform the paragraph. Thanks to
the macro, I was able to convert
dozens of those boxy paragraphs in
just a couple of minutes.

I'm sure you can find many uses
for macros. Once you do, you'll
probably want to copy some of those
macros to templates or other
documents so that others can use

them.
roug | %@{7&_

To copy macros from Normal.dot
(the default template) to another file,
use the Organizer:

1. Click Tools>Templates and
Add-ins.

2. Click the Organizer button. The
Organizer dialog box appears.

3. Click the Macro Project Items
tab. By default, the macros stored in
Normal.dot are displayed on the
right side (source file), and the
macros stored in the current docu-
ment are displayed on the left side
(target file).

4. Select an appropriate source and
target file by clicking the associated
Close File button. When clicked,
the button toggles to an Open File
button.

5. Click the Open File button, and
choose the appropriate file.

6. Select a macro to copy from the
source side, and click the < <Copy
button. The selected macro is cop-
ied to the target side. (The same
process works for Styles, AutoText
entries, and Toolbars.)

7. Click the Close button when
finished.

You can store macros in document
and template files. You can leave all
of your macros in the Word
Normal.dot file, but if anything
should happen to this file, Word
recreates it and your macros are lost.
An alternative is to store the macros
in a “utility” document or template
from which the macros can be copied
and used elsewhere as needed.

Word macros used over and over
save you a tremendous amount of
time, with no programming required.
If you do want to try your hand at
programming macros, the VBA
(Visual Basic for Applications)
language provides even more power
and capabilities.

Editor’s note: This article originally appeared
in Blue Pencil, the newsletter of the Pittsburgh

chapter of STC. i
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> New chapter
'@i@' officer

Chanda Child
named Internal
VP

By Kathy Graden

Chapter Secretary

he Phoenix Chapter board of
T directors has selected Chanda
Child as Internal Vice
President for 2001—
2002. Chanda has
graciously accepted
the board’s invitation
to fill the position, left
vacant when Internal
VP-elect Amy
Shogan resigned.
Since joining STC only three years
ago, Chanda has been very active in
Phoenix Chapter events. She was a
volunteer judge for CARSEF
(Central Arizona Science and
Engineering Fair) in 1999, 2000, and
2001 and served as CARSEF co-
chairperson in 2000. She worked on
the 1999 Region 5 Conference
Publications Committee. In 2000,
she was a publications judge in her
first PAO Competition. Chanda has
written articles for Rough Draft and is
one of three STC members who
presented “One-Source Documenta-
tion” at the March dinner meeting.
Chanda is an independent training
consultant who has been developing
and delivering classroom and
computer-based training in the Valley
since organizing her company,
Ocotillo Training, L.L.C., in 1997.
Over the past 16 years, she has
developed training in the fields of oil
exploration and refining,
manufacturing process control,
aerospace, and
telecommunications.

Chanda Child
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Pride and
recognition

By Linda Shacklock

Program Manager

honor Phoenix Chapter

volunteers and CARSEF award

winners at our annual awards
and honors banquet on June 12. Help
celebrate their achievements, and
hear Jim Morgan, a Phoenix chapter
past president, talk about perceptions
of technical communicators and why
we should take pride in what we do.

The title of Jim’s presentation is:

“I'm a writer.”

“Oh?”

“A technical writer.”

“Oh.”

It’s an unusual title, but it drives
home one of Jim’s key points—many
people outside our profession have no
idea of what we do or how we
contribute to the companies and
organizations that employ us.

Students whose technical papers
won awards at CARSEEF along with
their family members or teachers, will
be joining us for this special meeting,
so please come and help us welcome
and congratulate them.

The awards banquet closes the
2000-2001 chapter year. During July
and August, we will hold informal
chapter meetings with no programs
but lots of networking opportunities.
(See the Calendar in this issue for
date, time, and place information.)
Dinner meetings with guest speakers
will resume in September.

J une is the month in which we
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Awards and
honors
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Continuing a
tradition

By Kathy Graden

Newsletter Editor

ver the past few years, STC
O Society-level committees

have been generous to the
Phoenix Chapter and its members, to
the point where winning awards has
become a chapter tradition.

Since I came to the Valley in 1996,
the Society has honored us with two
Chapter Achievement Awards and
has named three Phoenix STC
members (Marian Barchilon, Tom
Barnett, and Freya Winsberg)
Associate Fellows. STC has bestowed
Distinguished Chapter Service
Awards on a select group of chapter
volunteers (including several people
who will receive awards at our awards
banquet this month). And the
publicity campaign for our 2000
Publications, Art, and Online
Competitions earned a Distinguished
Technical Communication Award.

Rough Draft has just extended this
winning streak by winning an award
of Excellence in the Society’s 2000
2001 Newsletter Competition. This
newsletter received the third highest
score in this year’s competition. And
this latest award is the 11th won by
the newsletter in 11 years.

With deep gratitude, I thank my
sharp-eyed copy editors, Carl Gotlieb
and Freya Winsberg. And without
Tom Barnett, John Brinegar, and
Dottie Tucker, the electronic version
of Rough Draft couldn’t exist. Thanks
also to all who contributed art,
articles, or ideas this past year.
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Thank you, corporate sponsors!

The Phoenix STC Chapter extends a heartfelt “Thank You” to the central Arizona companies
who supported chapter events and activities in 2000-200 | . Because of your generosity,
we had an extremely successful and rewarding chapter year!

Special recognition goes to the following corporations, which helped with multiple STC
events this year:

8alf River Projeof *Furnished meeting space, other amenities for chapter events.
*Subsidized employees’ time for the Society’s 2000-200 | STC
Rl Y Newsletter Competition and judging at the Central Arizona
Regional Science and Engineering Fair (CARSEF).
Dellvering More Than Power™ *Subsidized cost of printing services for monthly meeting

postcards, the Rough Draff newsletter, and the 2000 PAO
Compefitions banguet program.

*Donated printing for participation awards and other materials for
m participants in CARSEF.

*Gave employees time off to judge students’ papers at CARSEF.

*Donated employees’ time, supplies, meeting rooms, copying

@ P services, and training facilities for the PAO Competfitions.
AG Communication Sysiems
*Gave employees time off to judge students’ papers at CARSEF.

*Donated employees’ time to plan and organize the PAO
Competfitions and to judge students’ papers at CARSEF.

*Co-sponsored and helped to publicize Jane Smith’s seminars on
developing CBT and multimedia training.

ASTD

Linking People,
Learming & Performance

The following companies also receive warm thanks for donating
employees’ time or subsidizing costs for Phoenix Chapter events:  (SROEOUIP

GROUR 1 SOFTWARE

The Marketing Software Compeany™

Michaels and Associates, L.L.C. | —
BANK EONE

AR : nl!“p“ oo Bureau of Land Management

Training Provider

Adobe

mofive design

ACCESS LASE.RPRESS’

Ocatillo Training, L.L.C.
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